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Outline

Ø I Sistemi Embedded, cosa sono e a cosa servono

Ø I microcontrollori, la loro architettura

Ø L’architettura del processore ARM Cortex M4

Ø La board STM32F4-Discovery

Ø Il nostro obiettivo

Ø Materiale necessario per lo sviluppo del progetto
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I Sistemi Embedded

Ø Un Sistema Embedded (SE) (o Sistema Dedicato) è un sistema di 
elaborazione progettato per eseguire un insieme ristretto di 
funzioni per applicazioni specifiche (industriali, aerospaziali, 
automotive, ecc.) 

Ø Solitamente, come nel caso di un SE per il controllo treni, sono 
sistemi che operano in tempo reale, ovvero devono rispondere ad 
eventi esterni in tempi prestabiliti (deadline). Si parla in questo 
caso di Sistemi Real-Time. 

Ø Esempi di SE sono nel mondo che ci circonda ogni giorno: nelle 
lavatrici, nelle auto, nella macchina del caffè, nei cellulari.
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Cos’è un Microcontrollore

Ø I Sistemi Embedded sono basati sui Microcontrollori. I 
microcontrollori sono semplicemente “computer di dimensioni 
ridotte” all’interno di un singolo circuito integrato. Sono utilizzati 
per applicazioni specifiche  (Special Purpose).

Ø Un microcontrollore, così come un computer General Purpose, 
ha una memoria, può essere programmato per qualsiasi 
computazione, riceve input e genera output.

Ø Nella maggior parte dei casi i microcontrollori possono essere dei 
System-on-Chip. Ovvero incorporano all’interno di un singolo 
chip tutte le unità tipiche di un calcolatore: CPU, memoria, bus, 
interfacce I/O, periferiche.
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Embedded Systems vs General Purpose Computing

Ø Embedded Systems (Special 
Purpose)
o Eseguono singole applicazioni già 

note in fase di sviluppo del 
sistema

o Spesso hanno vincoli sul tempo di 
esecuzione. Non per forza, le 
performance devono essere alte

o In molte applicazioni hanno hard-
contraints sul consumo di potenza

Ø General Purpose
o Eseguono qualsiasi tipo di 

applicazioni
o Faster is always better
o Possono essere sempre 

riprogrammati da un utente 
finale
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Architettura Generale di un Microcontrollore

Ø Ogni microcontrollore integra:
o Il Processore (e.g. Intel, Arm)
o Una memoria (SRAM o DRAM)
o Una memoria flash
o Bus di comunicazione (e.g. 

Advanced Microcontroller Bus 
Architecture (AMBA)). Quasi 
sempre due bus a diverse 
frequenze di clock.

o Interfacce di Comunicazione 
(I2C, SPI, UART, etc.)

o ADC/DAC
o Clock
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Il Processore ARM Cortex M4

Ø Il processore ARM Cortex M4 e più in generale la famiglia M-series è 
un processore utilizzato per microcontrollori che garantisce bassi 
consumi di potenza con buone prestazioni

Ø E’ un processore che implementa il set di istruzioni (ISA) Thumb a 16 
bit che può essere visto come una forma compressa di un sottoinsieme 
dell'ARM Instruction Set (a 32 bit).

Ø Il processore presenta una pipeline a 3 stadi

Ø Gestisce le interruzioni in maniera innestata con meccanismi quale il 
Wake Up Interrupt Controller (WUIC) che permettono di ridurre il 
consumo di potenza
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Il Processore ARM Cortex M4
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La board di sviluppo STM32F4-Discovery

Ø La STM32F4-Discovery è una scheda di 
svilluppo che contiene al suo interno:
o Il microcontrollore STM32F4 basato sul 

ARM Cortex M4
o Accelerometro 3-axis
o Digital microphone
o Audio DAC
o Debugger
o Pin di interfacciamento con il mondo esterno 

(GPIO)
o Due pulsanti e 4 LED
o Jack audio 3.5 
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Il Microcontrollore STM32F4

Ø La STM32F4-Discovery è una scheda di 
svilluppo che contiene al suo interno:
o Il microcontrollore STM32F4 basato sul 

ARM Cortex M4

• Il  microcontrollore  STM32F4  presenta:
• ARM  M4  core  processor  168MHz
• 1MB  Flash
• 192KB  SRAM
• >  80  I/O  Pins
• 13  Timers
• Serial  Communications:  6  UARTs,  
3  SPI,  2  I2C

• USB  OTG  Controller
• External memory controller
• Internal DMA  System
• Ethernet  Controller
• SD  Controller
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Concetti di Base per la Programmazione dei 
Microcontrollori

Ø Programmare un microcontrollore significa istruirlo a fare una 
specifica funzione di interesse

Ø Per fare ciò noi scriveremo programmi in linguaggio C che 
saranno poi compilati (quindi tradotti in linguaggio macchina) per 
il nostro microcontrollore

Ø Il programma “tradotto” in linguaggio macchina sarà poi caricato 
nella memoria Flash del microcontrollore. Questa ha la 
caratteristica di mantenere la programmazione anche quando 
l’alimentazione al microcontrollore viene spenta 

Ø Durante l’esecuzione la RAM conterrà i dati, ovvero tutte le 
variabili che si utilizzano all’interno del programma
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Concetti di Base per la Programmazione dei 
Microcontrollori

Ø La programmazione dei microcontrollori si basa sulla scrittura in 
specifici registri di memoria (ad indirizzi prestabiliti) 

Ø Ogni periferica/unità ha il suo set di registri dedicati dal quale 
andrà a leggere per sapere come si deve comportare

Ø Ogni periferica/unità di un microcontrollore per funzionare 
necessita di essere inizializzata
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Sporchiamoci le mani: la Prima Programmazione 
della STM32F3

Ø Obiettivo: Si vuole programmare la scheda affinché premendo un 
pulsante si accenda un led.

Ø Di cosa abbiamo bisogno?

o La STM32F3 discovery

o Eclipse IDE

o ARM-GCC toolchain

o Debugger OpenOCD

o ST-LINK
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Intro
Ø Al fine di tenere un ambiente di sviluppo ordinato creeremo la 

cartella “ArmEnviroment” nel PATH principale “C:\”
Ø Questa operazione non è necessaria ma ci permetterà nelle varie 

esercitazioni di conoscere il PATH in cui sono localizzati i vari 
strumenti

Ø L’installazione dell’ambiente di sviluppo per la STM32F3 sarà 
effettuata attraverso gli eseguibili scaricabili da Google Drive:

https://drive.google.com/open?id=0B5pdTArYAQ51Zi03ZkdOOU
Y3TTg
Ø Tali eseguibili sono utili SOLO per installazioni su macchine 

Windows a 64bit
Ø Coloro i quali necessitassero di eseguibili per macchine a 32bit, 

potranno trovare opportuni link nel resto della presentazione
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Java Runtime Environment

Ø L’ambiente di sviluppo che utilizzeremo necessita della Java 
Runtime Environment

Ø Eseguire dunque jre-8u121-windows-x64.exe e procedere 
nell’installazione

Ø Altrimenti scaricare da qui l’eseguibile di interesse
http://www.oracle.com/technetwork/java/javase/downloads/jre8-
downloads-2133155.html
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Eclipse

Ø Eclipse è un Integrated Development Environment (IDE) ovvero 
un ambiente di programmazione open source. Eclipse è utilizzato 
per programmare in diversi linguaggi di programmazione (C, 
C++,Java, Rust, PHP, JavaScript, …)

Ø Eclipse non necessita di una procedura di installazione
Ø Scompattare l’archivio eclipse-cpp-neon-3-win32-x86_64.zip in 

C:\ArmEnviroment
Ø Altrimenti, scaricare Eclipse IDE for C/C++ developers da qui: 

http://www.eclipse.org/downloads/packages/
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ARM-GCC Cross Toolchain 1/4

Ø Il programma che scriveremo per controllare il led della scheda è 
scritto nel linguaggio di programmazione C

Ø Tale programma dovrà essere compilato per generare il codice 
macchina che il microcontrollore saprà eseguire

Ø Il compilatore nativo (e.g. gcc) genererebbe il codice macchina 
per l’architettura su cui si sta eseguendo la compilazione

Ø Noi dobbiamo compilare il codice per l’architettura specifica del 
microcontrollore

Ø A tal fine necessitiamo un Cross-Compiler il quale permette di 
generare un file binario eseguibile si di un’architettura diversa da 
quella della macchina su cui è stato lanciato il cross compiler
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ARM-GCC Cross Toolchain 2/4
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ARM-GCC Cross Toolchain 3/4

Ø Il primo passo da eseguire consiste nell’installazione del 
compilatore e degli strumenti di debugging per l’architettura 
ARM.

Ø Installare in C:\ArmEnvironment la nostra toolchain ARM 
armgcc-compiler.exe

Ø N.B. Prima di porre fine all’installazione spuntare “Add path
to enviornment variable”

Ø E’ possibile anche scaricare la tool-chain qui:
https://launchpad.net/gcc-arm-embedded/+download
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ARM-GCC Cross Toolchain 4
Ø Successivamente è necessario installare, in Eclipse, il plug-in relativo al 

cross compiler GCC per la piattaforma ARM Cortex.
Ø L’installazione può essere eseguita nel seguente modo:

o Scompattare in C:\ArmEnvironment il compresso plugin-eclipse-
armgcc.zip. Tale archivio lo si può trovare o nella folder Drive o al 
seguente link http://gnuarmeclipse.sourceforge.net/updates

o Andare in Eclipse

o Aprire il menu Help->Install New Software e cliccare su “Add” e poi
“Local”

o Indicare il path del plugin scompattato in precedenza. 
o N.B. Non selezionare la sottocartella plugins ma la root della cartella 

scompattata

N.B. al primo avvio Eclipse chiederà di specificare il path realtivo al workspace, 
quindi, per avere un facile accesso ai file di compilazione è consigliato specificare 

come path “C:\ArmEnvironment\workspace”
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Build Tools

Ø La compilazione dei driver e delle dipendenze necessitano di alcuni 
comandi presenti in ambiente linux. 

Ø I comandi linux vengono aggiunti all’ambiente windows mediante 
l’installazione di “MinGw”

Ø Installare in C:\ArmEnvironment mingw-w64-install.exe presente su 
Drive

Ø Oppure scaricarlo da qui: https://sourceforge.net/projects/mingw-w64/
Ø Andare nella cartella di installazione di MinGw all’interno della 

sottocartella bin (o bin-x64) e rinominare il file “mingw-make” a 
“make”

Ø Una volta completata l’installazione è necessario settare la variabile di 
ambiente PATH affinchè punti alla cartella dove sono presenti i binari 
di MinGW
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Set Environment Variable

Ø Per settare manualment il PATH 
“C:\ArmEnviroment\[InstallationFolderName]\bin” alle variabili d’ambiente di 
windows bisogna andare nelle impostazioni di sistema avanzate.

Aggiungere alla variabile “Path” il 
percorso “C:\Program Files\mingw-

w64\[NomeCartella]\mingw64\[bin o bin-
x64]”

NB:Se la variabile “Path” contiene altri valori 
utilizzare il simbolo ”;” come separatore
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ST-Link/V2

Ø ST-Link/v2 è il il modulo software che svolge le funzioni di 
linker.

Ø E’ utilizzato per caricare il file binario (senza effettuare debug), 
compilato con il cross compiler, all’interno del cortex M4

Ø Installare in C:\ArmEnvironment STM32 ST-LINK Utility v4.0.0 
setup.exe

Ø O scaricare il linker “STM32 ST-LINK utility” dall’indirizzo: 
http://www.st.com/web/en/catalog/tools/PF258168
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Debugger

Ø Il debugger è fondamentale nello sviluppo di software complessi. 
Ø Permette di scorrere l’esecuzione del codice “step-by-step” e di 

legger i valori intermedi di tutte le variabili utilizzate nel codice
Ø Il più famoso debugger è il GNU GDB utilizzato per verificare 

programmi C/C++ (https://www.gnu.org/software/gdb/)
Ø Si possono realizzare due tipologie di attività debugging:

o Local - Il debugging di un programma che esegue in locale 
sullo stesso sistema in cui si effettua il debug

o Remote – Il debugging di un programma che esegue su un 
sistema (detto target) differente da quello (detto host) su cui si 
esegue il debug
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STM32F4 Debugging

Ø Nel caso della STM32F4 ovviamente realizzeremo un remote
debugging. Faremo uso di OpenOCD.

Ø Questo si basa su una comunicazione client/server realizzata tra la 
scheda e il nostro calcolatore
o Un server OpenOCD, avente un file di configurazione 

specifico per la scheda su cui si vuole eseguire il programma, 
sarà lanciato sulla scheda e fornirà dunque informazioni al 
client sui valori nella memoria del microcontrollore.

o Un client sarà lanciato e comunicherà con il server per 
ottenere informazioni da fornire allo sviluppatore
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Debugger GDB and OpenOCD

Ø OpenOCD è un debbuger universale On-Chip.
Ø Attraverso un driver interno interagisce con le board che 

utilizzano il protocollo ST-Link 
Ø Scompattare il pacchetto openocd-0.9.0 dal link: 

http://www.freddiechopin.info/en/download/category/4-openocd
o Estrarre il pacchetto nella cartella “C:\ArmEnvironment”
o Rinominare la cartella di “openocd-0.9.0” in “openocd” 
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Configurazione di OpenOCD in Eclipse

Ø È possibile configurare Eclipse, in modo che utilizzi OpenOCD, 
attraverso il menu: Run ->External Tools -> External Tools 
Configurations

Aggiungere una 
nuova 

configurazione

Indicare il nome della configurazione

Inserire nel campo “Working Directory” la directory dove 
risiede OpenOCD

Nel campo “Arguments” viene indicato il 
file di configurazione realtivo alla  board
STM32F4. Il file di configurazione risiede 

nella cartella “scripts\board\” di 
OpenOCD

Inserire nel campo “Location” l’eseguibile di 
OpenOCD

Applicare la configurazione
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Configurazione di OpenOCD in Eclipse

Ø È possibile configurare Eclipse, in modo che utilizzi OpenOCD
andando a definire il path dove abbiamo installato il debugger: 
Window→ Preferences→ Run/Debug→ OpenOCD



The Fault and Intrusion Tolerant NEtworked SystemS (FITNESS)  Research Group
http://www.fitnesslab.eu/

Configurazione di OpenOCD in Eclipse

Ø Per la configurazione del client GDB in Eclipse, attraverso il 
menu selezionare il ragno di Debug->Debug Configurations -> 
GDB OpenOCD Debugging
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Configurazione client GDB

Ø Per la configurazione del client GDB in Eclipse, attraverso il 
menu selezionare il ragno di Debug->Debug Configurations

Ø Modificare solo la scheda “debugger” aggiungendo quanto 
riportato nell’immagine
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BlinkLed 1/

Ø Nei sistemi digitali il blink led costituisce l’esempio “Hello 
World”

Ø Creare un nuovo progetto dal menù “File->New->C Project

Inserire il nome del progetto

Selezionare “STM32F4xx” 
come tipo di progetto
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BlinkLed 2/

Ø Verificare che i vari campi siano settati come in figura:
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BlinkLed 3/
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BlinkLed 4/
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BlinkLed 5/

Ø Compilare il progetto cliccando sul martello
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BlinkLed 6/

Ø Se la compilazione è andata a buon fine, provare a “flashare” la scheda 
STM32F3

Ø Collegarla, avviare STLINK, connetterlo alla scheda cliccando sulla 
icona di presa elettrica. 

Ø Aprire (in file->open) il file da caricare sulla scheda. Tale file lo si può 
trovare nella cartella del progetto di Eclipse sotto (debug). Tale file ha 
estensione .hex

Ø Una volta aperto, lanciare il “program verify” tramite l’icona 
evidenziata. 

Ø Scollegare e ricollegare la scheda per vedere se il led lampeggia
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BlinkLed 7/
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Testare OpenOCD in Eclipse

Ø Una volta configurato il debugger, compilato il progetto di 
esempio, e collegato la scheda, lanciare il debug da Eclipse
premendo sul ragno di debug.
N.B. Chiudere ST-Link nel caso in cui lo si sia avviato in 
precedenza. In caso contrario, Eclipse riporterà un errore nel 
collegamento con la scheda

Ø Windows potrà chiedere che si accetti un rischio per la sicurezza, 
accettare!

Ø Eclipse chiederà se si vuole cambiare prospettiva su quella di 
debug, accettare!

Ø Se si è configurato il tutto correttamente il cambio di prospettiva 
di Eclipse sarà effettuato e vorrà dire che il debug potrà essere 
iniziato. 
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Esempi di Progetto da cui poter Iniziare

Ø La ST mette a disposizione degli sviluppatori un insieme di 
progetti utili per iniziare a sviluppare una specifica periferica.

Ø Il set di progetti che và sotto il nome di STMCubeMX è 
disponibile al seguente indirizzo: 

• http://www.st.com/en/embedded-software/stm32cubef3.html
• Dovremo dunque creare un nuovo progetto vuoto in Eclipse e 

importare gli opportuni file
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HAL 1/2

Ø Gli esempi riportarti in STMCubeMX fanno uso del Hardware 
Abstraction Layer (HAL)

Ø Come il nome suggerisce, l’ HAL introduce un livello di 
astrazione in più nell’interazione con il SoC

Ø In questo modo lo sviluppatore non dovrà preoccuparsi di 
interagire con l’HW dovendo quindi andare a scrivere nei registri 
delle differenti periferiche per configurarne l’uso.

Ø Avrà a disposizione delle API offerte dall’HAL che 
semplificheranno tale compito
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HAL 2/2
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Link

Ø Link Utili:
o Gruppo Google del Corso

• https://groups.google.com/forum/#!forum/corso-architetture-
parthenope-2017/new

o Link Tutorial
• http://www.robot-home.it/blog/software/tutorial-arm-stm32-

stm32f4-discovery-eclipse-gnu-toolchain-openocd-chibios-
sotto-windows/


